Mikrotik L2TP/IPsec včetně IPv6 u O2

Na internetu jsem hodně hledal, zda je možné si zpřístupnit IPv6 v síti operátora, který jej nepoužívá přes tunel, který bych si vystavil do domovské sítě, kde mi IPv6 funguje. Nejsem si jist, jestli jsem to dobře pochopil (a budu rád pokud mě někdo v komentářích opraví), ale ideální stav je od operátora dostat rozsah /56, který se pak rozdělí na /64 pro lokální síť a další rozsah /64 se přidělí VPN.
U O2 jsem dostal jen /64, čímž automaticky vše krásně bezstavově funguje ve vnitřní síti, ale přes VPN už není z čeho rozdávat.
Trochu jsem to obešel a díky 2 úpravám mi to funguje:

  • Přidal jsem pravidlo do IPv6 firewall, jelikož Windows při propojení VPN se pokusí poslat něco na IPv6, jestli je internet dostupný. Tento paket chytím a převezmu adresu zdroje, který použiji dále.
  • Přidal jsem skript do profilu VPN, který při připojení chvíli počká a pak se podívá, zda někdo neposlal paket IPv6 z tunelu. Vezme si adresu a přidá ji do route IPv6, čímž se stává stanice dostupná. Skript dále zakáže na firewallu pravidlo, jelikož po připojení již není potřeba. Po odpojení od VPN skript tuto routu smaže a zapne opět pravidlo a čeká, kdy se někdo připojí.
/ipv6 firewall filter
add action=add-src-to-address-list address-list=ipv6_source address-list-timeout=10s chain=input \
    in-interface=l2tp-vpn src-address=predpokladany_rozsah
add action=add-src-to-address-list address-list=ipv6_source address-list-timeout=10s chain=forward \
    in-interface=l2tp-vpn src-address=predpokladany_rozsah

/interface l2tp-server server
set allow-fast-path=yes default-profile=profile_vpn enabled=yes ipsec-secret="uplne_nahodne_heslo" \
    use-ipsec=yes
/interface list member
add interface=l2tp-vpn list=VPN
/ppp secret
add name=vpn_uzivatel password=vpn_heslo profile=profile_vpn remote-ipv6-prefix=\
    predpokladany_rozsah service=l2tp
/ppp profile
add bridge=bridgeLAN change-tcp-mss=yes dns-server=192.168.1.254 interface-list=LAN local-address=\
    192.168.1.199 name=profile_vpn on-down="/ipv6 route remove [/ipv6 route find where gateway=\"l2tp-vpn\"]\r\
    \n/ipv6 firewall filter enable [/ipv6 firewall filter find in-interface=\"l2tp-vpn\"]" on-up=":del\
    ay 6\r\
    \n/ipv6 route add gateway=l2tp-vpn dst-address=[([/ipv6 firewall address-list get [/ipv6 firewall \
    address-list find list=\"ipv6_source\"]]->\"address\")]\r\
    \n/ipv6 firewall filter disable [/ipv6 firewall filter find in-interface=\"l2tp-vpn\"]\r\
    \n\r\
    \n" remote-address=vpn_pool remote-ipv6-prefix-pool=o2
set *FFFFFFFE use-encryption=default use-ipv6=default

Leave a Comment

Vaše e-mailová adresa nebude zveřejněna. Vyžadované informace jsou označeny *

Translate »